What would cause a 15-year-old 15 kw Generac Guardian to have an overspeed error (and popped spark plug)?

Generac, Guardian, Honeywell, Siemens, Centurion, Watchdog, Bryant, & Carrier Air Cooled Home Standby generator troubleshooting and repair questions
Post Reply
HLB1982
New Member
New Member
Posts: 1
Joined: Fri May 17, 2019 5:20 pm

Fri May 17, 2019 5:22 pm

Hi --

We are not very familiar with generators, and this one came with the house. Our knowledge is pretty limited to checking and changing the oil, changing the filter, and replacing the battery.

We have a 15-year-old Generac Guardian 15 kw stand-by generator. It has about 108 hours of run time on it. Battery was just replaced, and oil and filter were recently changed. Today during its scheduled run cycle it struggled to start-up then stopped running after about 5 seconds.

It has an overspeed error and a popped spark plug won't go back in. It will run, but for no more than 60 seconds. Any idea what could be causing this? Is it something that we could potentially repair? Or, is this a job for an expert?
Chris
Site Admin
Site Admin
Posts: 601
Joined: Sat Aug 04, 2018 8:46 pm
Location: Clawson, MI
Contact:

Fri May 17, 2019 5:34 pm

What do you mean by "popped spark plug that won't go back in"?

The overspeed (if it's flashing) is most likely a brush/slip ring issue. As they age, the resistence between the brushes and slip rings increases and will eventually make the connection impossible for the voltage regulator and it will fail out on flashing overspeed (meaning no voltage output).
Generac tech for over 12 years. I'm here to help!
"The only source of knowledge is experience" -Albert Einstein
Looking for Generac parts? Gentek Power offers the full line of Generac replacement parts! Shop Gentek Power Generac Parts
A list of my favorite Generator & Electrical Tools! https://www.amazon.com/shop/gentek_power
78buckshot
Verified Dealer
Verified Dealer
Posts: 93
Joined: Mon Nov 12, 2018 9:45 am
Location: Stockbridge/Chelsea, Michigan

Fri May 17, 2019 10:00 pm

If the model number is a 4390 series then I would recommend replacing the ignition coils, the controller gets it's speed signal from the ignition and as they start to fail will give false info to the control. I'm also wondering what the "popped spark plug" is, please describe the issue.
Post Reply