geneator will not come up to speed / shuts down afte 5 seconds

Generac, Guardian, Honeywell, Siemens, Centurion, Watchdog, Bryant, & Carrier Air Cooled Home Standby generator troubleshooting and repair questions
Post Reply
Carlosm
New Member
New Member
Posts: 1
Joined: Thu Nov 07, 2019 10:38 am

Model 0043893 - 7000 Watt Natural Gas. one cylinder and the unit does not have a choke. The unit has been in storage for some time. Installed for the first time and is being wired directly to a residential panel without using the transfer switch. The unit will start up immediately with the panel rocker switch located under the top cover. The 30 amp breaker on the anel was slos in the off position. The unit lopes and does not get up to a reasonable speed. Shuts down after a few seconds. Tested the oil pressure switch and the oil level both good. Static gas pressure at the meter seems to be over 9 inches tested with a home maid manometer. 8 feet of 1 inch piping to the unit from the meter, so i'm pretty sure i would have enough volume.
looking for suggestions on where to go with the troubleshooting.
Chris
Site Admin
Site Admin
Posts: 1996
Joined: Sat Aug 04, 2018 8:46 pm
Location: Clawson, MI
Contact:

Well, I have a few questions...

1. Why is the unit backfeeding a residential panel like that? Or is this being used as the only supply to that panel?
2. Do you have a way to keep the battery charged, it will die without utility power unless the system fuse is pulled when not in use.
3. The natural gas pressure is too high at 9" if that's really what the pressure is based on the home made manometer.
4. Has anyone done a valve adjustment and general tune up on the unit?
Generac tech for over 12 years. I'm here to help!
"The only source of knowledge is experience" -Albert Einstein
Looking for Generac parts? Gentek Power offers the full line of Generac replacement parts! Shop Gentek Power Generac Parts
A list of my favorite Generator & Electrical Tools! https://www.amazon.com/shop/gentek_power
owner
New Member
New Member
Posts: 3
Joined: Mon Nov 25, 2019 4:30 pm

I have a similar 7k generator with a similar problem so posting here. My generator was connected to the house correctly by code (transfer switch). It has never been used only started manually occasionally since 2008. I start it monthly and let run for 10 min. Never a problem till I changed the oil. It is at the correct level. Now it manually starts as always but shuts down in @ 10 seconds.
Chris
Site Admin
Site Admin
Posts: 1996
Joined: Sat Aug 04, 2018 8:46 pm
Location: Clawson, MI
Contact:

owner wrote:
Mon Nov 25, 2019 4:42 pm
I have a similar 7k generator with a similar problem so posting here. My generator was connected to the house correctly by code (transfer switch). It has never been used only started manually occasionally since 2008. I start it monthly and let run for 10 min. Never a problem till I changed the oil. It is at the correct level. Now it manually starts as always but shuts down in @ 10 seconds.
When it shuts down, what is the error light that lights up, or does it just die? If it does just die, does it try to restart automatically a few seconds later?
Generac tech for over 12 years. I'm here to help!
"The only source of knowledge is experience" -Albert Einstein
Looking for Generac parts? Gentek Power offers the full line of Generac replacement parts! Shop Gentek Power Generac Parts
A list of my favorite Generator & Electrical Tools! https://www.amazon.com/shop/gentek_power
owner
New Member
New Member
Posts: 3
Joined: Mon Nov 25, 2019 4:30 pm

Thank you for your reply.
It just shuts down and all green lights flash.
This generator hardly has an hour on it and always starts immediately.
Since this happened after changing oil it has to be related but the oil level is perfect.
BTW does this brand have an automatic low oil shut-off ?
Thanks
owner
New Member
New Member
Posts: 3
Joined: Mon Nov 25, 2019 4:30 pm

Chris Today I tried starting it again. Ran for 15 seconds and cut out. This time the red light for low oil came up( I can't believe I missed that before but it's possible). Makes more sense since this happened after an oil change.
The filler dip stick shows full ??
Chris
Site Admin
Site Admin
Posts: 1996
Joined: Sat Aug 04, 2018 8:46 pm
Location: Clawson, MI
Contact:

It's possible that you may have damaged the switch when removing the oil filter, or possibly got oil on the switch and caused an issue. You can do 1 of 2 things.
1. Verify that the unit DOES in fact make oil pressure when running for those 15 seconds with a mechanical oil gauge like the one found here: https://amzn.to/2QVtC3E It's nothing more than an old automotive gauge with some tubing. You'll probably have to swing into a hardware store and get a 1/8" NPT to 1/4" NPT adapter to screw into the oil pressure hole on the gen.
2. Just install a new oil pressure switch and hope that it fixes it. The pressure switch you have now is most likely the older 1-wire style which has since been replaced by this 2-wire switch and install kit for the 7kW found here: https://shop.gentekpower.com/products/g ... e-switches
Generac tech for over 12 years. I'm here to help!
"The only source of knowledge is experience" -Albert Einstein
Looking for Generac parts? Gentek Power offers the full line of Generac replacement parts! Shop Gentek Power Generac Parts
A list of my favorite Generator & Electrical Tools! https://www.amazon.com/shop/gentek_power
Post Reply