Page 1 of 1

Generator will not start - no led's lit

Posted: Sat May 11, 2019 4:22 pm
by BobES3
I have a 16KW Gardian Model 0052430 Serial 4776364 running on LP. Installed in 2007 and never a problem. We lost power in a rain storm and it did no come on line. Battery was dead although it exercised on time 3 days earlier. I jumped the battery and got it started on Auto but it would not switch. Made a manual switch and started and ran fine on manual. When the power returned I discovered the battery (although taking a full charge) FAILED a load test. I cleaned the unit with air and brushes and replaced the battery. Now it will not start on Manual or Auto. There are no lit LEDs on the control board and there is 12V to the 15 amp fuse.
I have amp meter, VOM, pressure gauges, a pretty good set of tools and testers. The unit has gotten regular maintenance and never had a problem. The battery that was replaced was 4 1/2 years old and the second battery in the life of the unit.

Re: Generator will not stard - no led's lit

Posted: Sat May 11, 2019 5:58 pm
by Chris
Is the battery now dead again? If so, it probably has a bad charger. The charger can be tested simply by measuring AC voltage into the charger to confirm it's powered. AC voltage should be about 19VAC at the upper 2 wire connector. The 3 wire connector that only has 2 wires is the output. DC voltage should be about 13.5-14V

If the charger is bad, you can find it here: https://shop.gentekpower.com/products/g ... a1801-more

Re: Generator will not stard - no led's lit

Posted: Mon May 13, 2019 8:55 am
by BobES3
No. It is a new battery and has a full charge.

Re: Generator will not stard - no led's lit

Posted: Mon May 13, 2019 1:14 pm
by 78buckshot
Check for battery voltage on both sides of the fuses, the fuse holder is prone to failure or poor connection. If the LEDS are dead then that points to no power at the board.

Re: Generator will not stard - no led's lit

Posted: Mon May 13, 2019 2:35 pm
by BobES3
THANKS!! Unplugged and re-plugged the spade connectors. Lights on. Set exercise. Runs great and does what you expect it to do in Auto and Manual

Re: Generator will not stard - no led's lit

Posted: Mon May 13, 2019 7:45 pm
by 78buckshot
Good to hear, thanks for the update.