Welcome to the Gentek Power Generator Repair Forum!

Find out who we are & why we're here!
Site Admin
Site Admin
Posts: 7025
Joined: Sat Aug 04, 2018 8:46 pm
Location: Clawson, MI

Hey Pete,

Sorry I missed this message! I think we spoke about this on the phone the other day as well. We talked about lowering the sensitivity of them in the software. Just wondering if that worked?
Generac tech for over 12 years. I'm here to help!
"The only source of knowledge is experience" -Albert Einstein
Looking for Generac parts? Gentek Power offers the full line of Generac replacement parts! Shop Gentek Power Generac Parts
A list of my favorite Generator & Electrical Tools! https://www.amazon.com/shop/gentek_power
New Member
New Member
Posts: 2
Joined: Fri Dec 23, 2022 7:02 pm

New 18K generac generator.
There is a couple very short intermittent power outages last night. We were about 11° f The generator started then shut off a couple times. This morning it went into a error of the following.
Under voltage.
1902 error.
RPM sensor loss
Over Crank
I tried to run it in manual but it would not stay running for more than a couple minutes and then it shut down due to under voltage error.
I put the unit back in auto praying that it will run tonight if need be.
I never had any of these problems with my 22K. I hear comments about firmware updates but this is a 2022 model?
Model number g0072280
serial number 3008506746 firmware 1.15.176

Any help would be greatly appreciated.
Generator Jedi Master
Generator Jedi Master
Posts: 3635
Joined: Mon Apr 20, 2020 5:59 pm

Could be ice buildup on brushes. If it got too cold and moist, ice can build up snd prevent voltage production. You can try hitting area of stator by muffler with a hair dryer or heat gun and then starting it. If it runs ok, ice was cause.

Adding a heat sleeve to oil filter might help, as it adds some heat into engine compartment.
New Member
New Member
Posts: 2
Joined: Fri Dec 23, 2022 7:02 pm

Ok I can try that when I get back home. We will be away for a couple days.
I did try to start the gen. In manual before we left and it tried 4 time and never started. The battery seams fine 12.8 v. I'm not sure what to try next. This unit is only 7 months old. I have the error log on the app if needed.
What is 1902 error?
Thanks for the help.
Post Reply