Error code 1603-underspeed

Find out who we are & why we're here!
Post Reply
Cisco
New Member
New Member
Posts: 1
Joined: Wed Mar 03, 2021 2:31 pm

I have a generac 22kw evolution home generator. It is natural gas with a transfer switch. I have it set to run for 30 minutes once every 2 weeks. Lately, I have been getting an error code 1603-underspeed. It is 1.5 years old. I can't seem to find any material on the solution to the problem. Does anyone have thoughts?
Chris
Site Admin
Site Admin
Posts: 5998
Joined: Sat Aug 04, 2018 8:46 pm
Location: Clawson, MI
Contact:

The first odd thing I notice is that these won't run 30 minutes for an exercise, only 5, and that duration isn't changeable.

The underspeed is telling you that the engine isn't running fast enough. That is usually fuel related or a stepper motor issue. When you put the unit into Manual mode, do you see the throttle sweep back and forth before it cranks?
Generac tech for over 12 years. I'm here to help!
"The only source of knowledge is experience" -Albert Einstein
Looking for Generac parts? Gentek Power offers the full line of Generac replacement parts! Shop Gentek Power Generac Parts
A list of my favorite Generator & Electrical Tools! https://www.amazon.com/shop/gentek_power
jthiii
New Member
New Member
Posts: 1
Joined: Thu Aug 18, 2022 10:53 am

Hello,
I also have the same error message/ problem. Motor starts and runs for a short period of time at a low RPM and then shuts off displaying under speed error message.
My stepping motor does actuate throttle linkage moving it back and forth just prior to starting.
Any assistance regarding what could be causing this under speed would be greatly appreciated!
Unit has been working fine since I installed it a few years ago until recently when this problem developed.
grsthegreat
Generator Jedi Master
Generator Jedi Master
Posts: 2227
Joined: Mon Apr 20, 2020 5:59 pm

Dies this happen when exercising, or when running it in manual or during a power outage?
Goodwin3973
New Member
New Member
Posts: 3
Joined: Sat Jul 18, 2020 1:54 pm

I have a similar issue, it doesn't give me a code but it does say underspeed.
17kw generac Genie ,model#OH4655, 992cc, ser# E8854052 13073. shut down right away and said "underspeed". This is the second time i have come and found nothing wrong but customer has experienced a shutdown pretty quickly after call for electricity and startup. Giving an alarm "underspeed".
Tested fuel pressure, hertz and stepper motor. Cycled on/off several times while monitoring fuel pressure/hertz and sound. All good.checked connector for stepper and visionally saw it function. Also confirmed no real loads where present at time of alarm. I loaded it and tested all good. This doesnt happen when i am here and during maintenance cycle. There has been a code for check battery at each maintenance cycle.
I appreciate any help.

Tony
Chris
Site Admin
Site Admin
Posts: 5998
Joined: Sat Aug 04, 2018 8:46 pm
Location: Clawson, MI
Contact:

I would make sure all the battery connections are good and not corroded (since you're getting the battery alarms), and make sure that the unit is running normal speed during exercise, and not low speed (quiet test).
Generac tech for over 12 years. I'm here to help!
"The only source of knowledge is experience" -Albert Einstein
Looking for Generac parts? Gentek Power offers the full line of Generac replacement parts! Shop Gentek Power Generac Parts
A list of my favorite Generator & Electrical Tools! https://www.amazon.com/shop/gentek_power
Post Reply