Watchdog generator 15kw model 0053840

Terms & abbreviations we use here & some general generator information
Post Reply
Popcornman
New Member
New Member
Posts: 5
Joined: Sat Nov 07, 2020 5:07 pm

So generator started in Manuel mode, ran for 10 second shut off and a solid high speed light comes on. Took apart looked at brushes and look ok to me not much wear. See picture on brushes. What esle can it be? Again this is a 15kw watchdog generator.
Attachments
16047875986471326186807160086543.jpg
16047875986471326186807160086543.jpg (105.47 KiB) Viewed 121 times
20201107_154934.jpg
20201107_154934.jpg (67.14 KiB) Viewed 121 times
20201107_154940.jpg
20201107_154940.jpg (71.12 KiB) Viewed 121 times
Popcornman
New Member
New Member
Posts: 5
Joined: Sat Nov 07, 2020 5:07 pm

I made a video to maybe help out
grsthegreat
Generator Guru
Generator Guru
Posts: 451
Joined: Mon Apr 20, 2020 5:59 pm

Did you remove the bearing carrier and clean slip rings.
Popcornman
New Member
New Member
Posts: 5
Joined: Sat Nov 07, 2020 5:07 pm

So, i wasn't sure how to. Been trying to find a shop repair manual for it
Chris
Site Admin
Site Admin
Posts: 2959
Joined: Sat Aug 04, 2018 8:46 pm
Location: Clawson, MI
Contact:

The repair manual can be found here for it: https://shop.gentekpower.com/products/g ... tic-manual

I agree, without laying eyes on the slip rings, the brushes won't tell you much. What was the rotor resistance measured up at the AVR?
Generac tech for over 12 years. I'm here to help!
"The only source of knowledge is experience" -Albert Einstein
Looking for Generac parts? Gentek Power offers the full line of Generac replacement parts! Shop Gentek Power Generac Parts
A list of my favorite Generator & Electrical Tools! https://www.amazon.com/shop/gentek_power
Popcornman
New Member
New Member
Posts: 5
Joined: Sat Nov 07, 2020 5:07 pm

The resistance on the 2 middle wires i believe 0 & 4 and it was 38 on 2,000 this is on the 15kw generac generator.
Popcornman
New Member
New Member
Posts: 5
Joined: Sat Nov 07, 2020 5:07 pm

Ok, so snice the last post I ran it in manual mode for almost 10 mins, it was put out 150 volts at the gfi plug on the generator. Also when i went to put it in auto model and run it, gave the over speed flashing light code. Then i put it in manual mode and tried to run the couples house and it just made the lights flicker in the house never did run al the way

Chris
Site Admin
Site Admin
Posts: 2959
Joined: Sat Aug 04, 2018 8:46 pm
Location: Clawson, MI
Contact:

That unit is running WAY too slow! The voltage regulator is probably bad which is causing the high voltage, and it sounds like someone tried to turn down the engine speed to compensate.

38 ohms is about double what you should have. Should be about 19-22 ohms or so. They probably need to be cleaned.
Generac tech for over 12 years. I'm here to help!
"The only source of knowledge is experience" -Albert Einstein
Looking for Generac parts? Gentek Power offers the full line of Generac replacement parts! Shop Gentek Power Generac Parts
A list of my favorite Generator & Electrical Tools! https://www.amazon.com/shop/gentek_power
Post Reply